LATEST VERSION: v1.2 - RELEASE NOTES
Pivotal Container Service v1.0

PKS Prerequisites

Page last updated:

This topic describes the prerequisites for installing Pivotal Container Service (PKS) on vSphere or Google Cloud Platform (GCP).

General PKS Prerequisites

PKS requires the PKS Command Line Interface (PKS CLI) and the Kubernetes CLI (kubectl). See the following topics for information about installing each CLI:

Resource Requirements

For information about the resource requirements for installing PKS, see the topic that corresponds to your cloud provider:


Please send any feedback you have to pks-feedback@pivotal.io.

Create a pull request or raise an issue on the source for this page in GitHub