Redis for PCF Release Notes

Page last updated:

Breaking change: Before enabling TLS for on-demand service instances, you must follow the procedures in Preparing for TLS and ensure that you have configured the correct ports. For how to configure the ports, see Installing Redis for Pivotal Cloud Foundry.

Warning: If you are on Azure with AZ support and using Ops Manager v2.5, do not select the Allow outbound internet access from service instances checkbox on the On-Demand Service Settings pane. If you select this checkbox on these environments, you will receive an error message when running smoke tests or creating a service instance.

For product versions and upgrade paths, see Upgrade Planner.

v2.2.11

Release Date: April 23, 2020

Resolved Issues

This release has the following fix:

  • Static passwords are supported again.

Known Issues

There are no known issues for this release.

Compatibility

The following components are compatible with this release:

Component Version
Stemcell 621.x
Pivotal Platform 2.7.x and 2.8.x
Pivotal Cloud Foundry 2.5.x and 2.6.x
shared-redis-release 437.0.12
on-demand-service-broker 0.39.0
routing 0.199.0
service-metrics 1.12.5
service-backup 18.3.5
syslog 11.6.1
loggregator-agent 3.21.5
bpm 1.1.8
Redis OSS 5.0.7

v2.2.10

Release Date: April 17, 2020

Security Fixes

This release includes the following security fix:

Resolved Issues

This release has the following fixes:

  • Smoke tests no longer fail with Ruby buildpack v1.8.11 or later.

Known Issue

This release has the following known issue:

  • Configuring Redis services to use a static password results in the error secrets map doesn't consist of expected key. This is because of an issue with the handling of static passwords in the requirepass property.

Compatibility

The following components are compatible with this release:

Component Version
Stemcell 621.x
Pivotal Platform 2.7.x and 2.8.x
Pivotal Cloud Foundry 2.5.x and 2.6.x
shared-redis-release 437.0.12
on-demand-service-broker 0.39.0
routing 0.199.0
service-metrics 1.12.5
service-backup 18.3.5
syslog 11.6.1
loggregator-agent 3.21.5
bpm 1.1.8
Redis OSS 5.0.7

v2.2.9

Release Date: February 25, 2020

Security Fixes

This release includes the following security fix:

  • Fixes a security vulnerability in the CF Routing release.

Known Issues

This release has the following issues:

  • Smoke tests fail when run in environments with Ruby buildpack v1.8.11 or later.
  • Configuring Redis services to use a static password results in the error secrets map doesn't consist of expected key. This is because of an issue with the handling of static passwords in the requirepass property.

Compatibility

The following components are compatible with this release:

Component Version
Stemcell 621.x
Pivotal Platform 2.7.x and 2.8.x
Pivotal Cloud Foundry 2.5.x and 2.6.x
shared-redis-release 437.0.7
on-demand-service-broker 0.38.0
routing 0.198.0
service-metrics 1.12.5
service-backup 18.3.5
syslog 11.6.1
loggregator-agent 3.21.5
bpm 1.1.6
Redis OSS 5.0.7

v2.2.8

Release Date: December 4, 2019

Features

New features and changes in this release:

  • Updates open source Redis to v5.0.7.

Known Issues

This release has the following issues:

  • Smoke tests fail when run in environments with Ruby buildpack v1.8.11 or later.
  • Configuring Redis services to use a static password results in the error secrets map doesn't consist of expected key. This is because of an issue with the handling of static passwords in the requirepass property.

Compatibility

The following components are compatible with this release:

Component Version
Stemcell 456.x
Pivotal Platform 2.7.x
Pivotal Cloud Foundry 2.5.x and 2.6.x
shared-redis-release 437.0.1
on-demand-service-broker 0.35.0
routing 0.193.0
service-metrics 1.12.3
service-backup 18.3.4
syslog 11.6.0
loggregator-agent 3.21.4
bpm 1.1.5
Redis OSS 5.0.7

v2.2.4

Release Date: November 18, 2019

Security Fixes

This release includes the following security fixes:

Known Issues

This release has the following issues:

  • Smoke tests fail when run in environments with Ruby buildpack v1.8.11 or later.
  • Configuring Redis services to use a static password results in the error secrets map doesn't consist of expected key. This is because of an issue with the handling of static passwords in the requirepass property.

Compatibility

The following components are compatible with this release:

Component Version
Stemcell 456.x
Pivotal Platform 2.7.x
Pivotal Cloud Foundry 2.5.x and 2.6.x
shared-redis-release 436.1.2
on-demand-service-broker 0.34.1
routing 0.193.0
service-metrics 1.12.3
service-backup 18.3.4
syslog 11.6.0
loggregator-agent 3.21.4
bpm 1.1.5
Redis OSS 5.0.6

v2.2.2

Release Date: October 7, 2019

Security Fixes

This release includes the following security fixes:

Resolved Issues

This release has the following fix:

  • Configuring S3 service backups no longer results in an error due to a non-configurable property.

Known Issues

This release has the following issues:

  • Smoke tests fail when run in environments with Ruby buildpack v1.8.11 or later.
  • Configuring Redis services to use a static password results in the error secrets map doesn't consist of expected key. This is because of an issue with the handling of static passwords in the requirepass property.

Compatibility

The following components are compatible with this release:

Component Version
Stemcell 456.x
Pivotal Platform 2.7.x
Pivotal Cloud Foundry 2.5.x and 2.6.x
shared-redis-release 435.0.0
on-demand-service-broker 0.33.0
routing 0.188.0
service-metrics 1.12.1
service-backup 18.3.2
syslog 11.4.0
loggregator-agent 3.21.1
bpm 1.1.3
Redis OSS 5.0.5

v2.2.1

Release Date: August 27, 2019

Security Fixes

This release includes the following security fixes:

Known Issues

This release has the following issues:

  • Configuring S3 service backups results in an error due to a non-configurable property.
  • Smoke tests fail when run in environments with Ruby buildpack v1.8.11 or later.
  • Configuring Redis services to use a static password results in the error secrets map doesn't consist of expected key. This is because of an issue with the handling of static passwords in the requirepass property.

Compatibility

The following components are compatible with this release:

Component Version
Stemcell 315.x
Pivotal Platform 2.7.x
Pivotal Cloud Foundry 2.5.x and 2.6.x
cf-redis-release 434.3.12
on-demand-service-broker 0.31.1
routing 0.188.0
service-metrics 1.12.0
service-backup 18.3.1
syslog 11.4.0
loggregator-agent 3.21.0
bpm 1.1.1
Redis OSS 5.0.5

v2.2.0

Release Date: August 5, 2019

Features

New features and changes in this release:

  • Adds PCF Healthwatch indicators for on-demand plans. Healthwatch now shows metrics from newly-deployed service instances, with alert thresholds predefined. For more information, see the PCF Healthwatch documentation.

  • Operators can enable TLS for On-Demand Service Instances. Before doing this, ensure that you have followed the steps in Preparing for TLS and Network configuration.
    In most cases enabling TLS does not noticeably reduce performance. This depends, however, on network infrastructure, application architecture, and other such resources being in good shape.

Warning: After TLS has been enabled for the on-demand Redis service, disabling TLS causes downtime and service outage for all apps that connect to Redis through TLS.
If you disable TLS, you must unbind all apps bound to on-demand instances from the TLS port, rebind to the non-TLS port and then re-stage to resume service access.

Security Fixes

This release includes the following security fixes:

Resolved Issues

This release has the following fixes:

  • Smoke tests now run in the pivotal-services space.
  • The Deprecate Dedicated-VM Plan errand no longer runs.

Known Issues

This release has the following issues:

  • Configuring S3 service backups results in an error due to a non-configurable property.
  • Smoke tests fail when run in environments with Ruby buildpack v1.8.11 or later.
  • Configuring Redis services to use a static password results in the error secrets map doesn't consist of expected key. This is because of an issue with the handling of static passwords in the requirepass property.

Compatibility

The following components are compatible with this release:

Component Version
Stemcell 315.x
Pivotal Cloud Foundry 2.7.x
Pivotal Cloud Foundry 2.5.x and 2.6.x
cf-redis-release 434.3.12
on-demand-service-broker 0.31.1
routing 0.188.0
service-metrics 1.12.0
service-backup 18.3.1
syslog 11.4.0
loggregator-agent 3.18.0
bpm 1.0.4
Redis OSS 5.0.5

View Release Notes for Another Version

To view the release notes for another product version, select the version from the dropdown at the top of this page.