LATEST VERSION: 1.11.7 - CHANGELOG
RabbitMQ for PCF v1.9.16

RabbitMQ® for PCF Release Notes

Upgrade to the Latest Version

Pivotal recommends that you upgrade to the latest version of your current minor line, then upgrade to the latest available version of the new minor line. For example, if you use an older v1.7.x version, upgrade to the latest v1.7.x version before upgrading to the latest v1.8.x version.

See the Product Compatibility Matrix for product versions and upgrade paths.

View Release Notes for Another Version

To view the release notes for another product version, select the version from the drop-down list at the top of this page.

v1.9.16

Release Date: January 30, 2018

Features:

Known issues:

Packages:

  • OSS RabbitMQ v3.6.15
  • Erlang v19.3.6.4
  • HAProxy v1.6.13

v1.9.15 - Withdrawn

Release Date: January 24, 2018
Withdrawal Date: February 5, 2018

This release was withdawn due to an issue upgrading when there are special characters in the RabbitMQ administrator credentials. Skip this version and upgrade to v1.9.16 or later.

Features:

  • [Security Fix] Requires stemcell 3421.38 to address Spectre vulnerabilities.

Known issues:

Packages:

  • OSS RabbitMQ v3.6.14
  • Erlang v19.3.6.4
  • HAProxy v1.6.13

v1.9.14

Release Date: January 19, 2018

Features:

  • [Security Fix] Requires stemcell 3421.37 to address GNU C Library vulnerabilities.

Known issues:

Packages:

  • OSS RabbitMQ v3.6.14
  • Erlang v19.3.6.4
  • HAProxy v1.6.13

v1.9.13

Release Date: January 11, 2018

Features:

On-Demand

  • smoke-tests errand is renamed to on-demand-broker-smoke-tests
  • Some CF timeouts for smoke tests have increased

Known issues:

Packages:

  • OSS RabbitMQ v3.6.14
  • Erlang v19.3.6.4
  • HAProxy v1.6.13

v1.9.11

Release Date: December 14, 2017

Features:

Known issues:

Packages:

  • OSS RabbitMQ v3.6.14
  • Erlang v19.3.6.4
  • HAProxy v1.6.13

v1.9.10

Release Date: December 6, 2017

Features:

  • Requires stemcell 3421.32
  • Update to RabbitMQ v3.6.14 (release notes available here)
  • Update to Erlang 19.3.6.4
  • Go update (security fixes)
  • Minor updates in Pre-Provisioned service (multi-tenant broker):
    • Fix misspelling in log message
    • Improve service offering description

Known issues:

Packages:

  • OSS RabbitMQ v3.6.14
  • Erlang v19.3.6.4
  • HAProxy v1.6.13

v1.9.9

Release Date: November 2, 2017

Features:

  • Requires stemcell 3421.31
  • Enables shovel and federation plugins by default on on-demand instances
  • Enables the creation of administrator users for on-demand instances
  • Increases max HAProxy connections to 64000 for pre-provisioned plan
  • Removes the stats UI on HAProxy instances for pre-provisioned plan
  • Allows for more granular TLS protocol version selection for pre-provisioned plan
  • Fixes known issue where some invalid characters in the administrator password
  • Fixes a known issue where on-demand metrics were named /p-rabbitmq instead of /p.rabbitmq
  • Adds queue depth, memory alarm, and disk alarm metrics

Known issues:

Packages:

  • OSS RabbitMQ v3.6.12
  • Erlang v19.3.6.2
  • HAProxy v1.6.13

v1.9.8

Release Date: September 20, 2017

Features:

  • Requires stemcell 3421.26

Known issues:

Packages:

  • OSS RabbitMQ v3.6.12
  • Erlang v19.3.6
  • HAProxy v1.6.13

v1.9.7

Release Date: September 14, 2017

Features:

  • Update to RabbitMQ 3.6.12 — this involves major changes to the memory calculations.

Known issues:

Packages:

  • OSS RabbitMQ v3.6.12
  • Erlang v19.3.6
  • HAProxy v1.6.13

v1.9.6

Release Date: September 8, 2017

Features:

  • Adds the Partition Indicator metric.
  • Smoke tests are more resilient to cf domain re-ordering.
  • Updates cf-cli to v6.30 for cf commmand execution.

Known issues:

Packages:

  • OSS RabbitMQ v3.6.10
  • Erlang v19.3.6
  • HAProxy v1.6.13

v1.9.5

Release Date: August 21, 2017

  • Update to RabbitMQ 3.6.10
  • Requires stemcell 3421.20
  • This version of the tile can only be installed in an Ops Manager v1.10.3+ and v1.11 environments

Features:

  • Stemcell upgrade from the 3363 line to the 3421 line. Primary reason for the upgrade is to include the changes in 3421.18 which contains a fix for an rsyslog hanging issue that occurrs when the IPsec add-on is installed.

Known issues:

v1.9.4

Release Date: August 15, 2017

  • Update to RabbitMQ 3.6.10
  • Requires stemcell 3363.30
  • This version of the tile can only be installed in an Ops Manager v1.10.3+ and v1.11 environments

Features:

  • This is a security release addressed by a new stemcell

Known issues:

Packages:

  • OSS RabbitMQ v3.6.10
  • Erlang v19.3.6
  • HAProxy v1.6.11

v1.9.3

Release Date: August 8, 2017

  • Update to RabbitMQ 3.6.10
  • Requires stemcell 3363.29
  • This version of the tile can only be installed in an Ops Manager v1.10.3+ and v1.11 environments

Features:

  • This is a security release addressed by a new stemcell

Known issues:

Packages:

  • OSS RabbitMQ v3.6.10
  • Erlang v19.3.6
  • HAProxy v1.6.11

v1.9.2

Release Date: August 7, 2017

  • Update to RabbitMQ 3.6.10
  • Requires stemcell 3363.26
  • This version of the tile can only be installed in an Ops Manager v1.10.3+ and v1.11 environments

Features:

  • This version of the tile will use RabbitMQ Native Cluster formation rather than the rabbitmq-clusterer plugin.

Known issues:

Packages:

  • OSS RabbitMQ v3.6.10
  • Erlang v19.3.6
  • HAProxy v1.6.11

v1.9.1

Release Date: July 7, 2017

  • Update to RabbitMQ 3.6.10
  • Requires stemcell 3363.26
  • This version of the tile can only be installed in an Ops Manager v1.10.3+ and v1.11 environments

Known issues:

Packages:

  • OSS RabbitMQ v3.6.10
  • Erlang v19.3.6
  • HAProxy v1.6.11

v1.9.0

Release Date: June 30, 2017

  • Requires stemcell 3363.26
  • This version of the tile can only be installed in an Ops Manager v1.10.3+ and v1.11 environments

Known issues:

Packages:

  • OSS RabbitMQ v3.6.9
  • Erlang v19.3.6
  • HAProxy v1.6.11
Create a pull request or raise an issue on the source for this page in GitHub