Ops Manager v2.10 Release Notes

This topic contains release notes for Ops Manager v2.10.

Ops Manager is certified by the Cloud Foundry Foundation for 2020.

Read more about the certified provider program and the requirements of providers.


Releases

v2.10.0

Release Date: July 31, 2020

Ops Manager v2.10.0 uses the following component versions:

Component Version
Ops Manager2.10.0-build.48
Stemcell621.77
BBR SDK1.18.0
BOSH Director270.11.1
BOSH DNS1.21.0
Metrics Server0.0.24
System Metrics2.0.11
CredHub2.8.0
CredHub Maestro8.0.1
Syslog11.6.1
Windows Syslog1.0.3
UAA74.5.18
BPM1.1.8
Networking9
OS Conf22.0.0
AWS CPI81
Azure CPI37.2.0
Google CPI30.0.0
OpenStack CPI44
vSphere CPI54.1.0
BOSH CLI6.3.1
Credhub CLI2.7.0
BBR CLI1.7.2
Telemetry1.1.1

How to Upgrade

To upgrade to Ops Manager v2.10, see Upgrading Ops Manager.

New Features in Ops Manager v2.10

Ops Manager v2.10 includes the following major features:

Long-Term Support for Ops Manager v2.10

Ops Manager v2.10 is the long-term supported (LTS) version of Ops Manager. Ops Manager v2.10 will be supported through April 2024.

Over the lifecycle of Ops Manager v2.10, VMware will release security patches that occasionally include feature enhancements and maintenance updates.

The migration period for upgrading to Ops Manager v2.10 is from August 2020 to March 2021. To accommodate this migration and provide customers with additional time to upgrade to Ops Manager v2.10, Ops Manager v2.7 will be supported through March 31, 2021.

For more information about Ops Manager v2.10 LTS, please reach out to your Account Team.

BOSH Director Manifest Overrides

In Ops Manager v2.10, you can use the /api/v0/staged/director/overrides Ops Manager API endpoint to override properties in the BOSH Director manifest. With this endpoint, you can only override properties that appear in the instance groups and networks sections of the manifest.

You must be in Advanced Mode to use this feature.

For more information about this feature, see Overriding Manifest Properties in Advanced Mode.

For information on the Ops Manager API endpoints related to this feature, see Advanced Manifest Configuration in Ops Manager API Documentation.

Override Runtime Config Properties

In Ops Manager v2.10, you can override the runtime config properties for BOSH DNS and System Metrics.

You must be in Advanced Mode to use this feature.

You use the /api/v0/staged/director/runtime_configs/overrides endpoint in the runtime configs to override properties:

Runtime Config Names Add-on Names
ops_manager_dns_runtime
  • bosh_dns
  • bosh_dns_windows
ops_manager_system_metrics_runtime
  • system_metrics_agent
  • system_metrics_agent_windows

For example, although you cannot change the log level for the BOSH DNS logs through the Ops Manager UI, you can change the log level using the /api/v0/staged/director/runtime_configs/overrides endpoint. Increase the log level to DEBUG for more information or decrease the level for less verbose logs.

For more information, see:

View Certificates in the Ops Manager UI

The Ops Manager UI introduces a new page called Certificates. This page displays all the certificates listed by the /api/v0/deployed/certificates endpoint, as well as the following details:

  • Certificate name: The name of the certificate.
  • Product GUID: The product for which the certificate is issued, such as BOSH or MySQL.
  • Location: Whether the certificate is stored in Ops Manager or CredHub.
  • Type: Whether the certificate is a leaf certificate or a certificate authority (CA).
  • Configurable: Whether the certificate is configurable.
  • Valid until: The expiration date of the certificate and the number of days before expiration.

For more information, see Using the Ops Manager Interface.

CredHub Maestro Runs Safety Checks During Certificate Rotation

CredHub Maestro v8.0, which is included in Ops Manager v2.10, performs basic safety checks when rotating certificates to prevent unsafe operations.

The Ops Manager API invokes the CredHub Maestro CLI when rotating certificates. If an Ops Manager API certificate rotation command is out-of-order or unsafe, CredHub Maestro stops the command and returns one or more safety violation errors.

To observe this feature in Ops Manager v2.10 certificate rotation API calls, you must have Pivotal Application Service (PAS) v2.8.2 and later or TAS for VMs v2.9 and later installed, and you must not have any version of Tanzu Kubernetes Grid Integrated Edition (TKGI) installed. If you are using an earlier version of PAS or have any version of TKGI installed, Ops Manager still runs safety checks, but they are not as comprehensive as CredHub Maestro safety checks.


For more information, see Troubleshooting CredHub Maestro Safety Violations During Certificate Rotation, Rotating Certificates, and Advanced Certificate Rotation with CredHub Maestro.

Known Issues

There are no known issues for this release.