vSphere with NSX-T Version Requirements

Page last updated:

This topic describes the version requirements for installing Pivotal Container Service (PKS) on vSphere with NSX-T integration.

For prerequisites and resource requirements for installing PKS on vSphere without NSX-T integration, see vSphere Prerequisites and Resource Requirements.

For hardware and resource requirements for deploying PKS on vSphere with NSX-T in production environments, see Hardware Requirements for PKS on vSphere with NSX-T.

PKS supports air-gapped deployments on vSphere with or without NSX-T integration.

You can also configure integration with the Harbor tile, an enterprise-class registry server for container images. For more information, see VMware Harbor Registry in the Pivotal Partner documentation.

vSphere Version Requirements

PKS on vSphere with NSX‑T supports the following vSphere component versions:

Versions Editions
  • VMware vSphere 6.7 U1 EP06 (ESXi670-201901001) – for NSX-T 2.4
  • VMware vSphere 6.7 U1
  • VMware vSphere 6.7.0
  • VMware vSphere 6.5 U2 P03 (ESXi650-201811002) – for NSX-T 2.4
  • VMware vSphere 6.5 U2
  • VMware vSphere 6.5 U1
  • vSphere Enterprise Plus
  • vSphere with Operations Management Enterprise Plus

Note: VMware vSphere 6.7 is only supported with Ops Manager v2.3.1 or later and NSX‑T v2.3.

For more information, see Upgrading vSphere in an NSX Environment in the VMware documentation.

NSX-T Integration Component Version Requirements

Refer to the PKS v1.3 Release Notes for supported NSX-T versions.


Please send any feedback you have to pks-feedback@pivotal.io.