Skip to content

Upgrading Concourse v5.5.x to v6.3.x with BOSH

This guide provides a high-level overview of upgrading a Concourse deployment using BOSH, including command requirements and common errors.

Notes about breaking changes and other information can be found in the release notes.

Upgrade path

This guide instructs on how to upgrade from v5.5.x to v6.3.x - if you are using a previous release of Concourse for VMware Tanzu, consult previous upgrade guides to first migrate to v5.5.x before you continue.

Prerequisites

This is a guide to upgrading Concourse through BOSH, using the BOSH CLI v2 command bosh deploy.

The BOSH CLI must be installed before following the rest of this guide. For steps to install the BOSH CLI, see the BOSH documentation.

Important information before you begin

You must only backup or upgrade a working Concourse deployment. Before upgrading, fix any issues in your Concourse deployment. This is necessary to ensure your backup files are valid, and to prevent problems occurring during the upgrade procedure.

For more information, see Checking the health and status of your deployments.

Pivotal recommends these three steps for upgrading:

  1. Backup with BBR
  2. Upgrade Concourse and dependencies
  3. Validate your new deployment

When you are ready to begin, follow the steps in Backup and Restore Concourse with BBR.